You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
{{ message }}
Repository navigation
evaluation extra caps litellm below 1.97.0, so no release fixing GHSA-7hp6-4w63-5g45 / CVE-2026-114612 (critical) can be installed #7252
litellm<1.97.0,>=1.83.7; python_version < "3.14" and extra == "evaluation"
litellm<1.97.0,>=1.93.0; python_version >= "3.14" and extra == "evaluation"
litellm GHSA-7hp6-4w63-5g45 / CVE-2026-114612 (published 2026-10-27, critical, CVSS 3.1 9.9) affects 1.91.0 and later and is fixed in 1.100.4, 1.101.3, 1.102.2, 1.103.1 and 1.104.0rc2 and later series. Every allowed version is below 1.97.0, so the extra cannot be installed with a patched litellm on any Python: a resolver picks 1.96.2, which is in the affected range. On Python 3.14 the lower bound >=1.93.0 leaves no unaffected version at all; on older Pythons only the pre-1.91.0 releases of the 1.x google-cloud-aiplatform line (litellm<1.86.0) escape it.
Repro (Python 3.14.7, uv 0.13.4):
$ uv pip install --dry-run "google-cloud-aiplatform[evaluation]==2.7.0" "litellm>=1.100.4"
error: No solution found when resolving dependencies
cause: Because google-cloud-aiplatform[evaluation]>=2.7.0 depends on litellm{python_full_version < '3.15'}>=1.93.0,<1.97.0 and you require google-cloud-aiplatform[evaluation]==2.7.0, we can conclude that you require litellm>=1.93.0,<1.97.0.
And because you require litellm>=1.100.4, we can conclude that your requirements are unsatisfiable.
Downstream, apache-airflow-providers-google requires google-cloud-aiplatform[evaluation], so Airflow images on Python 3.14 ship the affected litellm and fail scanners on a critical finding.
Could the upper bound move to a range containing a patched release (1.104.x or 1.106.x), as #7233 and #7062 did for the earlier advisories? If something blocks it, what is it? I am not claiming the advisory is reachable through the evaluation client; it describes the LiteLLM proxy server.
I'd like to work on this. The cap <1.97.0 predates the litellm security fix and now blocks every patched release (fixed in 1.100.4+ per GHSA-7hp6-4w63-5g45). My plan: bump the evaluation extra to allow the fixed litellm series (>=1.100.4,<2 or whatever upper bound matches the team's policy), regenerate the constraints across all Python versions in setup.py, and run the evaluation test suite against the new floor to catch any litellm API breakage between 1.93-1.100. Given this repo's owlbot/regen workflow, I'd like to confirm the version floor you want (1.100.4 vs 1.101.3) before opening the PR, since the sync pipeline may overwrite hand-edited pins unless the change lands in the right source of truth.
Activity
AtharvRG commentedon Oct 31, 2026
I'd like to work on this. The cap
<1.97.0predates the litellm security fix and now blocks every patched release (fixed in 1.100.4+ per GHSA-7hp6-4w63-5g45). My plan: bump theevaluationextra to allow the fixed litellm series (>=1.100.4,<2or whatever upper bound matches the team's policy), regenerate the constraints across all Python versions insetup.py, and run the evaluation test suite against the new floor to catch any litellm API breakage between 1.93-1.100. Given this repo's owlbot/regen workflow, I'd like to confirm the version floor you want (1.100.4 vs 1.101.3) before opening the PR, since the sync pipeline may overwrite hand-edited pins unless the change lands in the right source of truth.